#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([\[\(])\s*|\s*([\]\)])"
Local $sString = "test(option)with[something]done" & @CRLF & _
"" & @CRLF & _
"test( option ) with[ something ] done" & @CRLF & _
"test( option) with[ something] done" & @CRLF & _
"test(option ) with[something ] done" & @CRLF & _
"test( option ) with[ something ] done"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)