import re
regex = re.compile(r"([\[\(])\s*|\s*([\]\)])")
test_str = ("test(option)with[something]done\n\n"
"test( option ) with[ something ] done\n"
"test( option) with[ something] done\n"
"test(option ) with[something ] done\n"
"test( option ) with[ something ] done")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)