use strict;
my $str = 'test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done';
my $regex = qr/([\[\(])\s*|\s*([\]\)])/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";