#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9][1-9][1-9]\d{2}\d*|[1-9][2-9]\d{3}\d*|[2-9]\d{4}\d*|\d{6}\d*)$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"102" & @CRLF & _
"999" & @CRLF & _
"444" & @CRLF & _
"333" & @CRLF & _
"9999" & @CRLF & _
"10001" & @CRLF & _
"10000" & @CRLF & _
"10930" & @CRLF & _
"10903" & @CRLF & _
"11022" & @CRLF & _
"11014" & @CRLF & _
"11099" & @CRLF & _
"11100" & @CRLF & _
"12011" & @CRLF & _
"20000" & @CRLF & _
"30000" & @CRLF & _
"11111" & @CRLF & _
"11562" & @CRLF & _
"11234" & @CRLF & _
"12453" & @CRLF & _
"22222" & @CRLF & _
"232312" & @CRLF & _
"200000" & @CRLF & _
"2000000" & @CRLF & _
"123123213" & @CRLF & _
"12321324343432434"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")