// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9][1-9][1-9]\d{2}\d*|[1-9][2-9]\d{3}\d*|[2-9]\d{4}\d*|\d{6}\d*)$").unwrap();
let string = "1
12
100
101
102
999
444
333
9999
10001
10000
10930
10903
11022
11014
11099
11100
12011
20000
30000
11111
11562
11234
12453
22222
232312
200000
2000000
123123213
12321324343432434";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}