re = /^([1-9][1-9][1-9]\d{2}\d*|[1-9][2-9]\d{3}\d*|[2-9]\d{4}\d*|\d{6}\d*)$/m
str = '1
12
100
101
102
999
444
333
9999
10001
10000
10930
10903
11022
11014
11099
11100
12011
20000
30000
11111
11562
11234
12453
22222
232312
200000
2000000
123123213
12321324343432434'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end