package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\D+`)
var str = `(626*) 34a2- 4387)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}