$re = '/\D+/m';
$str = '(626*) 34a2- 4387)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;