use strict;
my $str = '(626*) 34a2- 4387)';
my $regex = qr/\D+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";