#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\R"
Local $sString = "line1" & @CRLF & _
"line2"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)