use strict;
my $str = 'line1
line2';
my $regex = qr/\R/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";