import Foundation
let pattern = #"\R"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
line1
line2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)