using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bTom\b(?!.*\bThumb\b)";
string input = @"Tom No Thumbnail Here
Tom No T-humb Here
Tom Oh Thumb Here";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}