$re = '/\bTom\b(?!.*\bThumb\b)/';
$str = 'Tom No Thumbnail Here
Tom No T-humb Here
Tom Oh Thumb Here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);