re = /\bTom\b(?!.*\bThumb\b)/
str = 'Tom No Thumbnail Here
Tom No T-humb Here
Tom Oh Thumb Here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end