package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z]\w*(?:\s+[A-Z]\w*)+`)
var str = `I studied in King Saud University, which is in Riyadh, the capital of Saudi Arabia`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}