// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z]\w*(?:\s+[A-Z]\w*)+").unwrap();
let string = "I studied in King Saud University, which is in Riyadh, the capital of Saudi Arabia";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}