re = /\b[A-Z]\w*(?:\s+[A-Z]\w*)+/m
str = 'I studied in King Saud University, which is in Riyadh, the capital of Saudi Arabia'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end