$re = '/Ticket (?:#|ID): (\d+)/';
$str = '[Ticket ID: 309972] New Support Ticket Opened
Ticket #: 656398';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);