re = /Ticket (?:#|ID): (\d+)/
str = '[Ticket ID: 309972] New Support Ticket Opened
Ticket #: 656398'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end