using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<some-html-stuff\>\s*\K[A-Za-z0-9]+";
string input = @"<some-html-stuff>
sometext<more-html-stuff>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}