re = /<some-html-stuff\>\s*\K[A-Za-z0-9]+/m
str = '<some-html-stuff>
sometext<more-html-stuff>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end