$re = '/<some-html-stuff\>\s*\K[A-Za-z0-9]+/m';
$str = '<some-html-stuff>
sometext<more-html-stuff>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);