using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^078\d{7}$";
string input = @"0781234567
0784543213
0685252552";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}