$re = '/^078\d{7}$/m';
$str = '0781234567
0784543213
0685252552';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);