package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^078\d{7}$`)
var str = `0781234567
0784543213
0685252552`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}