use strict;
my $str = ':"\\u0001\\t\\u0018\\t\\u0001\\u000F\\u000B小开","udid":\\u007F';
my $regex = qr/\\u00[01][0-9A-F]|\\u007F/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";