$re = '/\\\\u00[01][0-9A-F]|\\\\u007F/m';
$str = ':"\\u0001\\t\\u0018\\t\\u0001\\u000F\\u000B小开","udid":\\u007F';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;