using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<<[^>]*?\n[^>]*>>";
string input = @"Organisation Name <<me.company.name>>
ABN/ACN <<me.company.abn>>
Contact Name <<me.name>>
<<me.PhoneNumber
'Another line>>
Email <<me.emailAddress>>
<<asdf
>>
<<
>>
Invoice Address
Notice Address (if not invoice Address)
<<table(“tableSites ”,me.company.sites,1)
’table first parameter is the bookmark that contains the table
‘The collection to apply to the table
‘and a number of rows that makes up the header (these are ignored)
>>
Connection Site Address NMI Start Date
<<codeobject.item.addressObject.Address>> <<codeobject.item.nmi>> <<codeobject.item.CurrentPricing.StartPeriod>>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}