import Foundation
let pattern = #"<<[^>]*?\n[^>]*>>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Organisation Name <<me.company.name>>
ABN/ACN <<me.company.abn>>
Contact Name <<me.name>>
<<me.PhoneNumber
'Another line>>
Email <<me.emailAddress>>
<<asdf
>>
<<
>>
Invoice Address
Notice Address (if not invoice Address)
<<table(“tableSites ”,me.company.sites,1)
’table first parameter is the bookmark that contains the table
‘The collection to apply to the table
‘and a number of rows that makes up the header (these are ignored)
>>
Connection Site Address NMI Start Date
<<codeobject.item.addressObject.Address>> <<codeobject.item.nmi>> <<codeobject.item.CurrentPricing.StartPeriod>>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)