use strict;
my $str = 'Organisation Name <<me.company.name>>
ABN/ACN <<me.company.abn>>
Contact Name <<me.name>>
<<me.PhoneNumber
\'Another line>>
Email <<me.emailAddress>>
<<asdf
>>
<<
>>
Invoice Address
Notice Address (if not invoice Address)
<<table(“tableSites ”,me.company.sites,1)
’table first parameter is the bookmark that contains the table
‘The collection to apply to the table
‘and a number of rows that makes up the header (these are ignored)
>>
Connection Site Address NMI Start Date
<<codeobject.item.addressObject.Address>> <<codeobject.item.nmi>> <<codeobject.item.CurrentPricing.StartPeriod>>
';
my $regex = qr/<<[^>]*?\n[^>]*>>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}