using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\b(?:(?R)|(?:(?!<\/?div).))*<\/div>";
string input = @"<div class=""main"">asdasd<div>jk<div>jkjk</div>jk</div></div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}