re = /<div\b(?:(?R)|(?:(?!<\/?div).))*<\/div>/m
str = '<div class="main">asdasd<div>jk<div>jkjk</div>jk</div></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end