$re = '/<div\b(?:(?R)|(?:(?!<\/?div).))*<\/div>/m';
$str = '<div class="main">asdasd<div>jk<div>jkjk</div>jk</div></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);