#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\s*<dd3:[^>]*>).*?>([^< ]+)<"
Local $sString = "PUT /mg/co.xml HTTP/1.1" & @CRLF & _
"Host: 19.16.7.59" & @CRLF & _
"User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gehko/20100101 Firefox/31.0" & @CRLF & _
"" & @CRLF & _
"<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<!-- THIS DATA SUBJECT TO DISCLAIMER(S) INCLUDED WITH THE PRODUCT OF ORIGIN. -->" & @CRLF & _
"<io:zzzz xmlns:io="http://kfj/ledm/iomgmt/2008/11/30" xmlns:dd="http://jkfhkj/dictionaries/1.0/" xmlns:dd3="http://jfja/dictionaries/2009/04/06" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://jcjhjk/ledm/iomgmt/2008/11/30 ../../schemas/gfjbj.xsd">" & @CRLF & _
" <io:aaaa>" & @CRLF & _
" <dd3:bbbb>hjgjg</dd3:bbbb>" & @CRLF & _
" </io:aaaa>" & @CRLF & _
" <io:ccccc>" & @CRLF & _
" <io:dddd>" & @CRLF & _
" <dd3:ffff>15.34.2.5</dd3:ffff>" & @CRLF & _
" </io:dddd>" & @CRLF & _
" <io:eeee>" & @CRLF & _
" <dd3:gggg>67</dd3:gggg>" & @CRLF & _
" </io:eeee>" & @CRLF & _
" <io:iiii>" & @CRLF & _
" <dd3:jjjj><script>jgfjkgkj</script></dd3:jjjj>" & @CRLF & _
" </io:iiii>" & @CRLF & _
" </io:cccc>" & @CRLF & _
"</io:zzzz>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")