import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\s*<dd3:[^>]*>).*?>([^< ]+)<";
final String string = "PUT /mg/co.xml HTTP/1.1\n"
+ "Host: 19.16.7.59\n"
+ "User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gehko/20100101 Firefox/31.0\n\n"
+ "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<!-- THIS DATA SUBJECT TO DISCLAIMER(S) INCLUDED WITH THE PRODUCT OF ORIGIN. -->\n"
+ "<io:zzzz xmlns:io=\"http://kfj/ledm/iomgmt/2008/11/30\" xmlns:dd=\"http://jkfhkj/dictionaries/1.0/\" xmlns:dd3=\"http://jfja/dictionaries/2009/04/06\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xsi:schemaLocation=\"http://jcjhjk/ledm/iomgmt/2008/11/30 ../../schemas/gfjbj.xsd\">\n"
+ " <io:aaaa>\n"
+ " <dd3:bbbb>hjgjg</dd3:bbbb>\n"
+ " </io:aaaa>\n"
+ " <io:ccccc>\n"
+ " <io:dddd>\n"
+ " <dd3:ffff>15.34.2.5</dd3:ffff>\n"
+ " </io:dddd>\n"
+ " <io:eeee>\n"
+ " <dd3:gggg>67</dd3:gggg>\n"
+ " </io:eeee>\n"
+ " <io:iiii>\n"
+ " <dd3:jjjj><script>jgfjkgkj</script></dd3:jjjj>\n"
+ " </io:iiii>\n"
+ " </io:cccc>\n"
+ "</io:zzzz>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}