use strict;
my $str = 'PUT /mg/co.xml HTTP/1.1
Host: 19.16.7.59
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gehko/20100101 Firefox/31.0
<?xml version="1.0" encoding="UTF-8"?>
<!-- THIS DATA SUBJECT TO DISCLAIMER(S) INCLUDED WITH THE PRODUCT OF ORIGIN. -->
<io:zzzz xmlns:io="http://kfj/ledm/iomgmt/2008/11/30" xmlns:dd="http://jkfhkj/dictionaries/1.0/" xmlns:dd3="http://jfja/dictionaries/2009/04/06" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://jcjhjk/ledm/iomgmt/2008/11/30 ../../schemas/gfjbj.xsd">
<io:aaaa>
<dd3:bbbb>hjgjg</dd3:bbbb>
</io:aaaa>
<io:ccccc>
<io:dddd>
<dd3:ffff>15.34.2.5</dd3:ffff>
</io:dddd>
<io:eeee>
<dd3:gggg>67</dd3:gggg>
</io:eeee>
<io:iiii>
<dd3:jjjj><script>jgfjkgkj</script></dd3:jjjj>
</io:iiii>
</io:cccc>
</io:zzzz>';
my $regex = qr/^(?=\s*<dd3:[^>]*>).*?>([^< ]+)</mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}