package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(.*?\)|\$|,`)
var str = `$16,500,000(@$2,500)
$34,000(@$11.00)
$214,000(@$18.00)
$12,684,000(@$3,800)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}