re = /\(.*?\)|\$|,/m
str = '$16,500,000(@$2,500)
$34,000(@$11.00)
$214,000(@$18.00)
$12,684,000(@$3,800)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result