import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(.*?\\)|\\$|,";
final String string = "$16,500,000(@$2,500)\n"
+ "$34,000(@$11.00)\n"
+ "$214,000(@$18.00)\n"
+ "$12,684,000(@$3,800)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}