using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(19|20)\d{2}[- :][VW][0-5](?(?=(?<=5))[0-2]|[0-9])";
string input = @"2016-W25
1980-V52";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}