$re = '/\b(19|20)\d{2}[- :][VW][0-5](?(?=(?<=5))[0-2]|[0-9])/';
$str = '2016-W25
1980-V52';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);