import re
regex = re.compile(r"\b(19|20)\d{2}[- :][VW][0-5](?(?=(?<=5))[0-2]|[0-9])")
test_str = ("2016-W25\n"
"1980-V52")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")