#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[()^|$[\]*.\\?{}]"
Local $sString = "^foo ba[rz]{1,2}$"
Local $sSubst = "\$&"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)