use strict;
my $str = '^foo ba[rz]{1,2}$';
my $regex = qr/[()^|$[\]*.\\?{}]/p;
my $subst = '\\$&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";