using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[()^|$[\]*.\\?{}]";
string substitution = @"\$&";
string input = @"^foo ba[rz]{1,2}$";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}