const regex = /\b\d{1,2}([\/\\]?)\d{1,2}\1\d{1,4}\b/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{1,2}([\\\/\\\\]?)\\d{1,2}\\1\\d{1,4}\\b', 'img')
const str = `12/31/2011 12\\31\\2011 12312011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}