re = /\b\d{1,2}([\/\\]?)\d{1,2}\1\d{1,4}\b/im
str = '12/31/2011 12\\31\\2011 12312011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end