$re = '/\b\d{1,2}([\/\\\\]?)\d{1,2}\1\d{1,4}\b/im';
$str = '12/31/2011 12\\31\\2011 12312011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);