$re = '/(<br\s*+\/?+>)++/i';
$str = 'Hello<br>
World<br><br />
Worlds<br><br><br>
Word!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);